Jump to content

Disertacion Sobre El Rendimiento Del Bs En Pos A Nuestro Pc...


Viper
 Share

Recommended Posts

Bueno, intentando exprimirle el maximo de FPS a mi BS ya que uso XP y no Vista y por lo tanto no puedo doblarle los FPS mediante los dos nucleos que tengo. He llegado a una conclusion, aunque si bien logica por lo que ya sabiamos, o por lo menos deducible, no calculada.

 

He estado tocando el tema graficos, y no solo los habituales, si no tambien las opciones avanzadas del Nvidia Control Panel, y los archivos del BS. Incluso he modificado los LOD, poniendoselo con los valores del Lockon que son mucho mas bajos. Y asi a groso modo podriamos decir que no le he sacado ni un FPS mas.

 

Y claro aqui viene la pregunta, como es posible que le baje increiblemente la calidad grafica y el esfuerzo y aun asi no suba los FPS. Primero como lo pruebo.

 

Yo tengo una mision creada en el editor, nada algo simple para mis practicas de vuelo y combate, pero que me es util para los FPS. Un aeropuerto, yo y mi punto, dos Mi-24v, dos Su33, 16 vehiculos aqui y alli, 4 infanteria, y el Kolgujev o como coño se escriba. Nada mas salir estoy con motor en marcha y mirando hacia el mar con algun edificio del aeropuerto dentro de mi cono de vision. Ahi los FPS suelen rondar los 30-40 FPS, aclarad que yo tengo limitado los FPS a un maximo de 40 para liberar recursos, es decir aunque pudiera el sim nunca me superaria 40. Pero lo importante es cuando miro a mi derecha atras y tengo a mi punto con una ciudad detras, entonces bajas a 20-25 FPS.

Bien, a pesar de todos los cambios en los graficos, los FPS cuando miro a mi punto siempre son iguales, pero, me parece haber notado una ganancia, no de FPS tal vez, si no de descarga de trabajo cuando miro a cualquier parte de la cabina. Cuando antes nada mas salir ponia zoom alejado a tope y mirado toda mi cabina, algo que hago siempre para que carge de buenas a primeras todas las texturas y demas de mi cabina, y que me ralentizaba el PC al principio de hacerlo, ahora parece que no sucede.

Eso sumado a que, los FPS si miro a mi punto son iguales, y lo que ya conocemos del Vista, deja claro que el BS puede dar muchos mas FPS de los que esta dando, y que viene limitado por el sistema operativo y la potencia de nuestro PC, amen de una optimizacion aun sin pulir del todo.

 

¿Que quiere decir esto? Pues que seguramente en parches futuros, estos FPS se nos iran aumentando con toda seguridad, y la migracion a Vista o a Windows 7 nos supondra un aprovechamiento casi total de la potencia del sim. No como hasta ahora que estamos muy limitados sobretodo los usuarios de XP.

 

De que optimizaciones del BS hablo por ejemplo, pues los modelos 3D de nuestros puntos, IA o Humanos. Que esta claro que ademas de consumir una gran cantidad de FPS, no estan del todo bien optimizados, ya que si fuera asi al bajar la calidad grafica, deberia subir los FPS al mirarlos. Ademas del modelo de daños que nos paraliza el PC durante unos segundos o centesimas a veces con suerte al petar uno de estos helicopteros.

Y muchas otras cosas, no apreciables con unas pruebas tan nimias.

 

Lo que si queda claro es que el sim puede dar mucho mas FPS de los que da ahora mismo, y solo gracias a un SO que use correctamente nuestro actuales equipos multinucleo y a un pulido y ajusto del propio sim, que seguramente llegara en forma de salto cuando lanzen el nuevo engine.

 

Hasta aqui mi analisis del estado actual del rendimiento del BlackShark, que si bien de profesional no tiene nada, me ha servido para distraerme un rato escribiendo :P

Edited by Viper
Link to comment
Share on other sites

Guest Darkness

Interesante sin duda tu reflexión. Yo puedo decir que estoy satisfecho, e incluso sorprendido, del rendimiento de BS. Después de haber escuchado muchos comentarios sobre rendimiento bajo etc, mi equipo, ya relativamente desfasado, consigue en nivel de calidad alto con water normal, sin tráfico, con efecto calor activado, a 1280x1024 y con cockpit en alta resolución unos aceptables 25-35 frames estables.

 

Hablo de un PC ya pasadito como digo, con Windows XP SP3, Intel Core 2 a 2,4, 2 gigas de RAM, y una Geforce 7900GT. Vamos un equipo que era bastante puntero cuando lo compré hace dos años y pico, pero que ahora necesita al menos un cambio de gráfica. Pensaba hacerlo, pero visto el rendimiento de momento estoy satisfecho y seguiré así hasta hacerme con una GTX260 de Nvidia.

 

Hay que tener en cuenta que sin duda el simulador, con mucha más carga gráfica, y en vuelo a baja cota, tira bastante bien. Recordemos cuando salió LOMAC, era imposible volar a baja cota si no tenías un superequipo de la época. Ahora se nota que está más optimizado. Y el procesador ahora es muy importante, prácticamente tanto como la gráfica, porque hay un gran e intenso cálculo de físicas que hace la CPU. En ese sentido los Core 2 son muy buenos, mucho mejores que los anteriores Pentium IV.

 

En definitiva, estoy muy contento con el BS en su versión 1.0. Buen rendimiento, mucho mejor de lo esperado, estable, buen online, y unos entornos terrestres muy buenos y que se nota se han trabajado para volar a baja cota. Se podrá mejorar claro, pero de momento creo que para una versión 1.0 es genial, recordemos otros simuladores y cómo suelen petar en sus primeras versiones.

 

Lástima lo de que no funcione el doble núcleo en XP, lo he probado yo también y no consigues prácticamente nada. Pero a pesar de ello no me cambio de Vista de momento eso está claro. Dicen fuentes fiables que, por fin, Windows 7 tiene una carga de recursos bastante menor que Vista y total compatibilidad. Esperemos que sea así. Yo pasaré entonces a Windows 7, que seguro aprovecha mucho mejor el doble núcleo.

 

En fin esas son mis primeras impresiones con el rendimiento, estoy muy contento con el BS en este sentido, por no hablar de la calidad de acabados del helo, simplemente genial.

Link to comment
Share on other sites

Guest Darkness

Con niveles medios te irá relativamente bien supongo, excepto por el Pentium IV no sé si te afectará mucho al rendimiento. Será interesante que comentes tus impresiones con tu equipo para comparar.

Link to comment
Share on other sites

Guest Darkness

Puedo asegurarte que el P4 le irá bastante peor que un Core 2 estándar. El core 2 es bastante más potente en potencia de cálculo que el P4, y hay casos extremos, por ejemplo, un P4 puede ejecutar dos instrucciones del IL-2 por ciclo de reloj, el Core 2 llega a ejecutar 5 instrucciones del IL-2 por ciclo de reloj.

 

Ojo, no te fies de la velocidad em Ghz, eso es lo de menos ahora, un Core 2 a 2,4 le da patadas a un P4 a 3,4.

Link to comment
Share on other sites

Mi equipo es un e6850 a 3Ghz , lo he subido a 3,30 Ghz y he ganado bastante la carga es mucho más rápida en el tema de frames he pasado de 30 -35 a 40 ó 50 dependiendo de la zona y "tuneando" también un poquito xp:

 

http://rapidshare.com/files/128526735/Acel..._-_60_Pages.rar (bajo vuestra responsabilidad , apuntad en libreta los cambios para poder revertirlos si algo no funciona)

 

Tampoco tengo ningún antivirus comiendo recursos .

 

:P

 

:rolleyes:

 

Olvidé decir que mi gráfica es una Sapphire RADEON X1950 .

Edited by Sergio -
Link to comment
Share on other sites

yo lo probé en mi equipo con vista tengo un core 2 a 1,6 4 gigas de ram y de grafica una x1950xt o sea un poco como el de darkness y la verdad me iba muy muy fino unos 30fps estable, ahora acabo de instalar el xp porque acabé del vista hasta los webs y no sé como andará pero ya no lo instalo hasta que no lo compre cuando salga en cajita. Por cierto cuando tuve el vista tenía que habilitar a manubrio el uso del otro core pero con el xp y el sp3 los 2 nucleos me aparecen activos desde el primer día.

Link to comment
Share on other sites

Guest Darkness

Señores, he pasado de los drivers de NVIDIA que tenía, los 175 y no recuerdo qué, a los últimos que hay disponibles para la serie 7, 178.24, y he ganado por toda la cara unos 10-12 frames!!! Ahora me da unos 43-45 frames estables :dance2: :vaca::game:

Link to comment
Share on other sites

Que suerte macho, yo sigo con mis 20-40 con los ultimos y penultimos drivers para 8800 GTX.

Tengo mejor grafica que tu pero menos FPS, deduzco que tendras una CPU mas pontente que la mia a 2.6Ghz, que estoy seguro me esta limitando mucho los FPS por culpa del multicore.

Link to comment
Share on other sites

Guest Darkness

:shok::shok:

 

Tendrías que tener muchos más frames que yo por todas partes, tanto por CPU como por tarjeta. Qué cosa más rara. Porque yo tengo de CPU un Intel Core 2 a 2,4, o sea el modelo anterior al tuyo, y una 7900GT. No sé si tendrás algo por ahí comiendo CPU o así, aunque yo no tengo todo a tope, sí a niveles alto, a ver si esta tarde pongo mi configuración, recuerdo el water a normal y alguna otra cosa no al máximo.

Link to comment
Share on other sites

Señores, he pasado de los drivers de NVIDIA que tenía, los 175 y no recuerdo qué, a los últimos que hay disponibles para la serie 7, 178.24, y he ganado por toda la cara unos 10-12 frames!!! Ahora me da unos 43-45 frames estables :dance2: :vaca::game:

 

He actualizado también a los últimos drives 180 y he perdido fps. Tenía los 175.16 y tenía una media de 30 fps mantenidos dentro de cabina con todo a tope.

Esta tarde limpiaré y volveré a instalarlos a ver si vuelve a quedar como antes.

Tengo una CPU 6750 Core 2 Duo con 4 Gb a 800 Mhz. La gráfica es una 8800 GT.

Se ve que tienes el pc muy bien afinado Darkness porque en teoría debería tener yo mejores resultados que tu. Pero mira por donde que no es así. <_<

 

Saludos.

Link to comment
Share on other sites

Guest Darkness

A ver, ¿no será por la gráfica? Es que es curioso que a ambos con 8800 tengáis o bien el mismo rendimiento o incluso menor. Creo recordar que había algún problema determinado con las 8800 en ciertas situaciones que provocaban rendimientos menores a los esperados. ¿Alguien se acuerda de lo que era? Porque no tiene ningún sentido que una 7900GT dé mejor rendmiento que una 8800GT, vamos tendría que ser que la 8800 diera bastantes más frames.

Link to comment
Share on other sites

Pues algo tiene que fallar por aqui si. Yo tengo los graficos mas bien bajos. Te pego aqui mi config. El water esta en blanco porque tengo el agua desactivada. Ademas tengo los arboles desactivados y el LOD lo baje a los valores del Lockon hace un par de dias.

 

dcsbsgraficosdd7.jpg

 

De CPU no creo que nada me lo este quitando, pero bueno hare una prueba, que con la pantallita LCD del G15 puedo ver lo que hacen los procesos sin tener que salir a windows.

¿Usas nhancer, o alguna pijada de esas?

Link to comment
Share on other sites

Guest Darkness

Otia, aparte que yo lo tengo a 1280x1024 por lo demás tengo una configuración bastante más alta que esa. Es que no me lo explico. El NHancer puede ir bien sin duda, ¿tendrás por casualidad activado el AA o el anisotrópico a nivel de driver de la tarjeta? Ojito con eso, prueba a desactivarlo si lo tienes a ver...

Link to comment
Share on other sites

Que va tio, tengo tanto el AA como el antisotropico controlados por el BS. El nHancer no lo tengo, lo preguntaba por si lo usas tu. Ademas he hecho estas pruebas y nada.

 

- Cambiando a resolucion 1024x768

- Cambiandole el aspecto de 16:10 a 4:3

- Asignando los dos cores.

- Asignado un core, pero el contrario por defecto.

- Poniendo en el panel de control de Nvidia General Alto Rendimiento.

- Cambiando todas las opciones graficas desde dentro del BS, sin tocar los archivos.

- Quitando el Rivatuner.

- Asignandole la prioridad a muy alta.

 

Y no se si me dejo algo mas, pero nada sigo igual, ademas ningun de esos cambias a variado en nada los FPS, siempre he ido con el mismo limite, lo cual deja claro que algo me esta limitando, sea del BS o de mi PC. El unico que ha supuesto diferencia de FPS a sido cuando tocando las opciones graficas desde dentro he puesto el Full Planar, el Heat, y el Water a normal y no recuerdo si algo mas, pero ha sido para peor claro.

 

¿Cuanta RAM tienes?

 

EDITADO: Enviame tus archivos graphics.cfg y options.lua, a ver si es algo en concreto lo que me esta limitando de ellos, los probare en mi pc.

Edited by Viper
Link to comment
Share on other sites

Viper, eso te debería ir mucho mejor, yo tengo un AMD 5800+ (2,8Ghz) con una 8800GT 256MB y 4GB 800Mhz 4-4-4-12 y lo tengo a tope menos water, sin AA pero con anisotrópico a 8x y a 1680x1050 y el Freetrack en background, sin overclocking. Drivers uso los 185.20, pero con los 184.48 y los 184.84 va igual. WinXP 32bit.

 

Intenta volver a configurar los gráficos desde 0, igual has tocado algo que no le sienta bien. ¿Puede ser que con el OC le hayas bajado la velocidad/latencia a la ram?

Link to comment
Share on other sites

Me ha ido igual de FPS desde el primer dia, por lo que no creo que sea por algo que haya tocado, mas bien pienso que pudiera ser que se instalara diferente desde base, no se.

El OC de la ram es 4-4-4-15 1:1 bajado de 800mhz a 667Mhz, asi que no deberia ser eso.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

Some pretty cookies are used in this website