Jump to content

SERVIDOR FUERA DE LÍNEA


Recommended Posts

Hola.

 

Necesito ayuda, a ver si alguien puede guiarme a cerca del siguiente tema.

 

Unos pilotos virtuales y yo hemos creado un servidor para volar algunas misiones que hemos creado pero a la hora de buscar el servidor (cualquiera de los creados porque a todos nos pasa lo mismo) no lo visualizamos, sólo lo ve el creador con ping 1. Si intentamos ingresar mediante dirección IP, nos aparece el mensaje de "SERVIDOR FUERA DE LÍNEA".

Tenemos puertos abiertos, firewall y antivirus desactivados, etc, pero no hay manera de que aparezca.

Hemos buscado por todos sitios y lo único que encontramos es el tema de abrir puertos, antivirus, firewall, misma versión de DCS...

 

Espero podáis ayudarnos porque la verdad que hemos hecho de todo y no encontramos solución.

 

Un saludo pilotos virtuales.

Link to post
Share on other sites

Hola.

Sin mirar mas a fondo, solo puedo especular. Pero mi experiencia me dice que el problema es, por orden de probabilidad:

- Tienes los puertos abiertos en el router, pero están mal

- El ordenador que hace de servidor no tiene la red local bien configurada

- El servidor no está en la misma versión que los clientes.

- Teneis un problema de hardware (NIC dañada, cable defectuoso....)

Intenta entrar en el TS una tarde, con alguien que tenga acceso al servidor, y podremos intentar ayudar.

 

Saludos y suerte

Link to post
Share on other sites

Hola Deute.

Gracias por responder.

 

Te explico un poco.

- Todos hemos creado un servidor con las mismas características.

- Abrimos los puertos.

- Quitamos antivirus.

- Misma versión DCS.

- Etc.

A todos nos da el mismo error, sea quien sea quien abra el server, en la página principal no aparece y si los buscamos por IP siempre están fuera de línea.

 

A tus consejos en orden.

- En teoría según mi router los puertos están bien abiertos, aunque desconozco si hay alguna forma de comprobar que realmente estén bien.

- Lo de la red local bien configurada no se exactamente a qué te refieres y cómo se puede ver.

- La misma versión del servidor no se si te refieres a "versión dcs". Todos volamos juntos en otros server públicos.

- Problema de hardware todos a la vez y sin embargo volamos en otras misiones publicas, podría ser pero tendríamos el mismo problema no para volar? 

 

La verdad es que es un quebradero de cabeza porque volamos en momentos muy puntuales y estos problemas hacen que perdamos mucho tiempo comprobando cosas.

 

Muchas gracias de nuevo Deute y si necesitas ver algún dato del server, puertos, etc me lo dices y lo pongo.

 

Un saludo.

 

 

Link to post
Share on other sites

Si os pasa a los 4, independientemente de quien abra el servidor, es que estais configurando el NAT igual de mal los 4, no veo otra. Eso si, hay una cosa que no tiene sentido, tal y como lo entiendo:
 

9 hours ago, RGBC said:

no lo visualizamos, sólo lo ve el creador con ping 1.

 

Cómo puede el creador verse a si mismo? O uno crea una partida en lugar de conectarse a otro server, y no puede "verse a si mismo", o bien monta la partida en un ordenador diferente al que usa como cliente... ¿Habéis hecho eso los 4?

 

De todas formas, si podemos hablar en el TS avanzaremos mucho mas

Link to post
Share on other sites

Para crearlos seguimos los pasos de la guía  Cómo crear un Servidor Dedicado en DCS" y todo perfecto. Ejecutamos icono dcs, abrimos index.html, la página se nos abre, corremos la misión, etc, todo perfecto. Vamos a multiplayer buscamos el nombre del server y aparece, como los otros miles que hay corriendo, pero sólo le aparece al que inicia el servidor, el resto no lo ve ni buscándolo ni introduciendo IP.

 

En cuanto sepa como insertar una imagen os pongo cómo lo tenemos.

 

Muchas gracias a todos.

 

 

Link to post
Share on other sites

El que crea el servidor, que pinche en el nombre del servidor y mire qué IP muestra el mismo. Seguramente sea una IP local del tipo 127.0.0.1 o 192.168.x.x . En cuyo caso no está con los puertos abiertos. Puede ocurrir que, aunque él tenga los puertos abiertos correctamente, aguas arriba (el suministrador de internet) no le permita utilizar ésos puertos. Yo he tenido problemas con éso mismo anteriormente

Link to post
Share on other sites

Lo sé, lo que os estoy diciendo es que lo comprobéis. Porque si él está hosteando es normal que vea el servidor porque estará en red local o en su propio PC, pero los demás no. La forma de comprobarlo es ver la IP que muestra el servidor dentro de DCS una vez vuestro compañero lo busca en multijugador

Link to post
Share on other sites
  • 1 month later...

Buenas tardes, refloto este hilo porque tengo una pregunta a ver si me aclaro.

No se si se ha pasado por alto algo obvio: el pc que hace de servidor no puede volar? Solo se usa de servidor? A ver si ese es el problema (espero que si). 

 

Muchas gracias. Saludos. 

 

 

Link to post
Share on other sites

Hola Fisu.

 

Tenemos los puertos abiertos, tanto el 8088 como el 10308 pero no hay manera. Estando registrado en DCS, abriendo la página de servidores (no recuerdo cómo se llama) lo inicia y pone la misión corriendo, todo en teoría como debiera, pero nada, no aparece al buscarlo en multiplayer.

 

Link to post
Share on other sites
On 12/20/2020 at 11:25 AM, JOSETI said:

Y seguro que tenéis IP pública todos? A ver si estáis metidos en cg-nat. 

 

Si no lo estáis el puerto es el 10308 tcp/udp. Y tienes que abrirlo a la IP que te de con cmd ipconfig. 

 

Un saludo. 

Me vuelvo a citar, a esto ni has respondido.

 

Un saludo.

Link to post
Share on other sites
El hace 1 hora, RGBC dijo:

Hola Fisu.

 

Tenemos los puertos abiertos, tanto el 8088 como el 10308 pero no hay manera. Estando registrado en DCS, abriendo la página de servidores (no recuerdo cómo se llama) lo inicia y pone la misión corriendo, todo en teoría como debiera, pero nada, no aparece al buscarlo en multiplayer.

 

Mirar lo que os está diciendo @JOSETI porque si tenéis los puertos abiertos, blanco y en botella. Llamar a vuestra compañia de telefono y que os saque de ahí. 

Link to post
Share on other sites

Hola.

 

Sí que estamos todos con los puertos abiertos, lo dije al principio del hilo, además hemos intentado hacerlo desde varios ordenadores, desde ordenadores libres dejándolos sólo como server y siguiendo varias de las guías que hay publicadas en varias webs y nada. 

En cuanto pueda subo fotos para que veáis como tenemos todo por si os da alguna pista en la que no hayamos caído. 

Link to post
Share on other sites

Lo ideal sería el TS, el problema es que mi disponibilidad para conectarme sería a altas horas de la noche y a saber qué día (generalmente volamos en fin de semana y de madrugada prácticamente). Pero si en algún momento puedo conectarme intento pediros ayuda por TS.

De todas formas muchísimas gracias por la ayuda y en cuanto pueda os subo fotos.

Link to post
Share on other sites
On 12/20/2020 at 11:25 AM, JOSETI said:

Y seguro que tenéis IP pública todos? A ver si estáis metidos en cg-nat. 

 

Si no lo estáis el puerto es el 10308 tcp/udp. Y tienes que abrirlo a la IP que te de con cmd ipconfig. 

 

Un saludo. 

 

1 hour ago, RGBC said:

Hola.

 

Sí que estamos todos con los puertos abiertos, lo dije al principio del hilo, además hemos intentado hacerlo desde varios ordenadores, desde ordenadores libres dejándolos sólo como server y siguiendo varias de las guías que hay publicadas en varias webs y nada. 

En cuanto pueda subo fotos para que veáis como tenemos todo por si os da alguna pista en la que no hayamos caído. 

Me vuelvo a citar, otra vez, y ya es la segunda vez. Que yo sepa aun no has respondido a la primera pregunta de mi post, ni mucho menos a mi teoría que comento después. Uno ayuda pero si de la otra parte no se pone interés, mas allá de tengo los puertos abiertos por sexta vez. 

 

Un saludo.

Link to post
Share on other sites

Para JOSETI.

 

1) Y seguro que tenéis IP pública todos? SÍ. 

2) A ver si estáis metidos en cg-nat. NO. (además creo recordar que vodafone no usa CGNat) 

3) Si no lo estáis el puerto es el 10308 tcp/udp. , además del 8088 (lo digo de cabeza)

4) Y tienes que abrirlo a la IP que te de con cmd ipconfig. Sí.

 

JOSETI Si necesitas algún dato más me dices y en cuanto pueda te contesto.

 

Como digo en otro hilo del e69 mi disponibilidad de tiempo y dedicatoria a DCS es bastante escasa y a horas bastante intempestivas debido a mi trabajo y vida familiar, no es que pase de contestar o no muestre interés, es que realmente no puedo, eso no quita el hecho de que lo poco que pueda intente disfrutar con los amigos, ellos te lo pueden corroborar. 

Agradezco mucho tu ayuda de verdad pero quizás estoy confundiendo términos o piense que te refieres a algo de lo que ya hemos hablado. Todo lo que se y entiendo que deberíais conocer sobre mi configuración y conexión os lo estoy exponiendo. 

Si necesitas que mire alguna cosa más dímelo.

 

Muchas gracias a JOSETI y a todos.  

Link to post
Share on other sites

No sé si valdrá. Yo reinstalé el ordena y en el router tenía configurado lo de abrir y cerrar los puertos y resulta que la IP que aparecía era la de la antigua instalación no la nueva.

 

Cambié y puse la nueva en el router y todos los problemas desaparecieron.

 

Por si te vale de ayuda.

Edited by Trazador
Link to post
Share on other sites
13 hours ago, Matador_11_ said:

Arreglao, culpa mía, al revisar los mensajes he revisado la dirección ip en el router y habia una que bailaba un número....

 

Pues podrías haberlo arreglado antes de navidades:

On 12/19/2020 at 9:28 PM, Deute said:

Sin mirar mas a fondo, solo puedo especular. Pero mi experiencia me dice que el problema es, por orden de probabilidad:

- Tienes los puertos abiertos en el router, pero están mal
....

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

Some pretty cookies are used in this website