Sign in to follow this  
heracles

Parpadeo (flickering) en las texturas del cielo - Solucionado

Recommended Posts

Bueno,

 

esto de configurar de nuevo el equipo va a acabar conmigo. En mi antiguo PC tenia una ATI y todo me iba de maravilla. Ahora este cacharro de portátil tiene una NVDIA y me estoy haciendo migas configurándola de forma decente.

 

Total que he conseguido que todo vaya bien en PERFECT MODE, menos un molesto parpadeo de las texturas del cielo. Y me pasa lo mismo en la 4.12, como en el HSFX 6.0 (4,11) y en el UP 3.0 RC4 (4.10):

j86y.jpg

 

En la imagen salen rallas fijas pero cuando muevo el punto de vista la cosa desaparece y vuelve. Lo curioso es que en en EXCELLENT (HardwareShaders=0) todo va perfecto. Aunque claro las texturas del suelo y el mar ya no aparecen en perfect mode. Y lo raro es que siempre he creído que el perfect mode sólo cambiaba las texturas del suelo y el mar y que no influía para nada en el cielo. Está claro que me equivocaba. Algo hace, no se el qué, pero algo hace.

 

En fin, he buscado por todos los foros pero la cosa tiene mala pinta. Parece que es un problema de compatibilidad del driver de mi tarjeta gráfica (NVIDA QUADRO K1000M) con el OpenGl 1.2 que gasta el IL-2. Sólo posteaba por si alguien ha tenido exactamente el mismo problema con una NVIDIA. Os dejo los settings de la sección [Render_OpenGL]. Se que éste es un tema recurrente y muy trillado, pero es que cada vez que cambiamos de equipo es mas difícil hacer que el IL-2 funcione a pleno rendimiento por problemas de compatibilidad de su versión de OpenGL tan arcaica.

 

[Render_OpenGL]
TexQual=3
TexMipFilter=2
TexCompress=0
TexFlags.UseDither=1
TexFlags.UseAlpha=0
TexFlags.UseIndex=0
TexFlags.PolygonStipple=0
TexFlags.UseClampedSprites=0
TexFlags.DrawLandByTriangles=1
TexFlags.UseVertexArrays=1
TexFlags.DisableAPIExtensions=0
TexFlags.ARBMultitextureExt=1
TexFlags.TexEnvCombineExt=1
TexFlags.SecondaryColorExt=1
TexFlags.VertexArrayExt=1
TexFlags.ClipHintExt=0
TexFlags.UsePaletteExt=0
TexFlags.TexAnisotropicExt=1
TexFlags.TexCompressARBExt=1
TexFlags.TexEnvCombine4NV=1
TexFlags.TexEnvCombineDot3=1
TexFlags.DepthClampNV=1
TexFlags.SeparateSpecular=1
TexFlags.TextureShaderNV=1
HardwareShaders=1
Shadows=2
Specular=2
SpecularLight=2
DiffuseLight=2
DynamicalLights=1
MeshDetail=2
VisibilityDistance=3
Sky=2
Forest=2
LandShading=3
LandDetails=2
LandGeom=2
TexLarge=1
TexLandQual=3
TexLandLarge=1
VideoSetupId=17
Water=4
Effects=1
ForceShaders1x=0
PolygonOffsetFactor=-0.15
PolygonOffsetUnits=-3.0
Saludos y gracias compañeros.

 

 

Edited by Bucaral
Editar etiquetas y título

Share this post


Link to post
Share on other sites

Tienes el setup en maxium settings en el apartado de grafic card?? es importante tenerlo...

Ya de paso pon el landgeom en 3, no vaya a ser eso...

Edited by McKinley

Share this post


Link to post
Share on other sites

Buenas compañeros,

 

de momento no hay manera. He probado con los settings de Patrel y tampoco. La cosa tiene que ser complicadilla... Todo apunta a la mala compatibilidad con OpenGL 1.2 del controlador de mi tarjeta gráfica y eso no va a tener fácil remedio... En fin seguiré probando a ver si hay suerte.

 

Gracias!

Share this post


Link to post
Share on other sites

Pero has ido al setup en el tipo de tarjeta y has puesto maxium settings ??

 

Otra cosa es en la tarjeta gráfica desactivar que esté controlada por la aplicación. Hay una pestaña que pone desactivar cualquier control de la aplicación o algo así. Sí quieres quedamos el viernes lora ts y comparamos configuraciones.

Share this post


Link to post
Share on other sites

Pues gracias McKinley, pues si el viernes coincidimos por el TS, repasamos los settings.

 

Pero las tarjetas gráficas de estos portátiles son bastante raras. Están pensadas para aplicaciones como Autocad, etc y me temo que el controlador no debe ser muy amigo de los simuladores creados en el 2001 con OpenGL 1.2. El controlador ya lleva implementado OpenGL 4.3 y no tengo muchas esperanzas. En todo caso siempre puedo volar sin "perfect mode".

 

Otra cosa sería que encontráramos a alguien que le rule bien el IL-2 con mi tarjeta gráfica: NVIDIA QUADRO K1000M

 

Saludos y a ver si nos podemos oír el viernes.

Share this post


Link to post
Share on other sites

Pues gracias overlord,

 

desde luego es el tutorial para gràficos de il-2 más completo que he visto.

 

McKinley, hoy no podré estar por el TS. Cualquier dia que nos crucemos hacemos una revisión del conf.ini. A ver que tal.

 

Pero he perdido la esperanza. He encontrado un thread del 2012 en el foro de 1c con el mismo problema que yo. Y son los drivers con el 99.99% de seguridad. En algún momento los de Nvidia han roto la compatibilidad en los drivers de la familia Quadro con alguna característica de OpenGl 1.2 que utiliza el IL-2 para renderizar el cielo.

 

La única opción que me queda es pillar el driver más viejo compatible con mi targeta y rezar para que funcione.

 

Saludos.

Share this post


Link to post
Share on other sites

Bueno pues parece que ya está.

 

Me he bajado un driver del 2012 compatible y esto ya funciona. La madre que los parió... Pero cómo no se les ocurre tener en sus test de calidad una prueba del mejor simulador del mundo :arge:

 

Vale que ya tiene unos años, pero que no nos jodan ioga! :icon_mrgreen:

 

Con lo bonito que es ver en perfect mode cómo quedan hechas añicos esas fabricas del enemigo cuando les pasa la Trueno por encima.... aiinnnsss que recuerdos :aplauso-6:

 

En fin gracias a todos por la ayuda.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this