JMCAL62

DCS no reconoce Warthog, ni MFD Cougar, ni pedales Thrustmaster

Recommended Posts

  •  
  •  

Hola a todos. Antes que nada quiero presentarme en este foro que me han dicho que es el mejor con mucha diferencia sobre simulación aeronáutica.

 

Si bien ha sido siempre mi pasión. nunca he tenido tiempo de dedicarme, pero ahora puedo hacerlo a tiempo completo pues me acabo de jubilar. Así que soy un novato "veteranito".

 

Mis conocimientos son básicos-medios y para meterme en este mundo le he echado cuenta a veteranos y me he hecho con lo que me han dicho que es lo mejor del mercado: el HOTAS WARTHOG, dos MFD Cougar y unos pedales Thrusmaster. Tengo un monitor curvo de 27 pulgadas y un I7 con 16 mb de Ram y una Geforce 1060. (y unas HTC VIVE)

 

Mi primer problema gordo es que ni DCS, ni Elite, ni Il2 reconocen ni el Hotas, ni los MFD. ni los pedales. Sin embargo FSX si lo hace, por lo que entiendo que los controladores están bien insatalados y están actualizados (los descargué desde la página de Thrustmaster) Llevo unas 90 horas volando con el A-10C con el teclado y el ratón para familiarizarme y más o menos lo estoy consiguiendo, pero me da mucho coraje no poder montar el equipo completo. 

 

Aunque sé que tendré que crear perfiles una vez los reconozca ¿qué puedo hacer para arreglar esto y que toda esta pasta que me he gastado funcione? ¿Algún alma caritativa que guíe a este novato senior por este mundo tan apasionante sin cachondearse en exceso de mi?

 

Pago cervezas virtuales en bitcoins.

 

PD: Como tampoco sé muy bien cómo funciona E69, a lo peor me estoy metiendo en contramano consultando por aquí y hay otro sitio específico para esto. Ruego también si alguien me puede guiar en esto.

Share this post


Link to post
Share on other sites

Primero bienvenido al foro.

 

Veamos, no vuelo DCS ni Elite pero es muy raro que sí te lo pille el FSX. Esto significa que el pc reconoce los periféricos así que debe ser otra cosa.

 

Como sólo he volado el IL2 de los que has comentado a ver si puedo ayudarte ahí. Supongo que hablas del BOS (Battle of Stalingrad), ¿no? No lo he volado mucho pero lo tengo medio configurado.

1º Entra en el juego y vete a los controles (key mapping). Verás que hay tres columnas para cada control.

2º Vete al apartado "main controls" (lo tengo en inglés), las filas 6, 7 y 8 se corresponde al control del avión (giñada, alabeo y timón).

3º Pulsa en añadir o "add new action" en la tercera columna y mueve el joy. Lo de q lo hagas en la tercera columna es por si tienes algo puesto ya en las dos primeras.

 

Una imagen vale más que mil palabras:

 

wmlcpc.jpg

 

A ver si te lo añade y así saber si sólo tienes que añadir los controles o es otra cosa.

 

Puff que mal explico las cosas leñe.

 

Suerte y que lo arregles lo antes posible.

Edited by Raidou
  • Like 1

Share this post


Link to post
Share on other sites

En DCS ni en otro sim, no tiene por que pillarte el cabeceo , alabeo y guiñada por si solo, tienes que configurar el sim y todos sus ejes de 0, añ igual que el resto de botones, por lo menos yo he tenido que hacerlo asi con todos y dispongo del mismo hardware que tu mas o menos.

  • Like 1

Share this post


Link to post
Share on other sites
2 minutes ago, overlord74 said:

En DCS ni en otro sim, no tiene por que pillarte el cabeceo , alabeo y guiñada por si solo, tienes que configurar el sim y todos sus ejes de 0, añ igual que el resto de botones, por lo menos yo he tenido que hacerlo asi con todos y dispongo del mismo hardware que tu mas o menos.

El Warthog pilla todo de primeras, salvo el trim y alguna cosas más, y los MFDs igual, son enchufar y volar. Al menos para el módulo del A-10C.

90 horas volando con teclas, ya te vale amigo :grin:

Vete a la pestaña de configuración, seleccion A-10Sim y luego a la derecha, asignación de ejes, y ahí tendrá que salir todo.

Donde veas alabeo y cabeceo, pues pincha y asigna el eje del joystick.

Donde veas gases o palanca de gases, pincha y mueve la palanca, para que lo detecte y asigne.

Con eso de primeras, luego guarda el perfil con un nombre, arriba a la derecha, para tenerlo ya salvado.

  • Like 1

Share this post


Link to post
Share on other sites
El hace 4 horas, Raidou dijo:

Primero bienvenido al foro.

 

Veamos, no vuelo DCS ni Elite pero es muy raro que sí te lo pille el FSX. Esto significa que el pc reconoce los periféricos así que debe ser otra cosa.

 

Como sólo he volado el IL2 de los que has comentado a ver si puedo ayudarte ahí. Supongo que hablas del BOS (Battle of Stalingrad), ¿no? No lo he volado mucho pero lo tengo medio configurado.

1º Entra en el juego y vete a los controles (key mapping). Verás que hay tres columnas para cada control.

2º Vete al apartado "main controls" (lo tengo en inglés), las filas 6, 7 y 8 se corresponde al control del avión (giñada, alabeo y timón).

3º Pulsa en añadir o "add new action" en la tercera columna y mueve el joy. Lo de q lo hagas en la tercera columna es por si tienes algo puesto ya en las dos primeras.

 

Una imagen vale más que mil palabras:

  Ocultar contenido

wmlcpc.jpg

 

A ver si te lo añade y así saber si sólo tienes que añadir los controles o es otra cosa.

 

Puff que mal explico las cosas leñe.

 

Suerte y que lo arregles lo antes posible.

Muchísimas gracias Raidou. Te explicas perfectamente, pero ya había llegado a ese punto; lo que pasa (y sigue pasando) es que cuando voy a asignar el control de lo que sea (en estos casos guiñada, alabeo y timón) al darle a añadir nueva acción no me reconoce el joy, como si no existiera y yo no me hubiera gastado la pasta, vamos. Y claro, ya no sigo con el resto del Hotas  ni pedales porque tampoco existen, leches que le dieron.

Será una tontería, probablemente y alguien de con la solución pero mientras tengo un cabreo del 15.

Share this post


Link to post
Share on other sites
El hace 1 hora, overlord74 dijo:

En DCS ni en otro sim, no tiene por que pillarte el cabeceo , alabeo y guiñada por si solo, tienes que configurar el sim y todos sus ejes de 0, añ igual que el resto de botones, por lo menos yo he tenido que hacerlo asi con todos y dispongo del mismo hardware que tu mas o menos.

Hola y encantando Overlord.

Como ya comento, el problema no es que tenga que hacer el mapeo (aunque creía que el Warthog era plug an play con DCS A-10C al ser reproducción exacta). El problema es ni DCS, ni IL2 BOS, ni Elite Dangerous  reconocen que estén conectados ninguno de los periféricos, y ya comento que los controladores están bien instalados pues FSX si reconoce los tres. (el HOTAS, los MFD y los pedales).

En la opción de controles de cualquiera de estos otros tres simuladores aparecen solo teclado y ratón. Y consiguientemente no se pueden asignar ejes ni nada más que no sea a través de teclado y ratón.

¡S.O.S!

Share this post


Link to post
Share on other sites
El hace 1 hora, Tundra dijo:

El Warthog pilla todo de primeras, salvo el trim y alguna cosas más, y los MFDs igual, son enchufar y volar. Al menos para el módulo del A-10C.

90 horas volando con teclas, ya te vale amigo :grin:

Vete a la pestaña de configuración, seleccion A-10Sim y luego a la derecha, asignación de ejes, y ahí tendrá que salir todo.

Donde veas alabeo y cabeceo, pues pincha y asigna el eje del joystick.

Donde veas gases o palanca de gases, pincha y mueve la palanca, para que lo detecte y asigne.

Con eso de primeras, luego guarda el perfil con un nombre, arriba a la derecha, para tenerlo ya salvado.

Encantado, Tundra.

Eso pensaba yo, que en DSC el A-10c sería plug and play aunque luego tendría que mapear muchas cosas.

Esas 90 (ya 92) horitas volando con el teclado y el ratón van a gastarme los dedos, pero me han servido para familiarizarme con el 90% del avión y sus características. Pero estoy hasta los tegumentos procreativos ya. Con el equipo que me han traído los Reyes y sin poderlo usar.

Pero insisto, el problema es que en configuración/A-10C sim/asignación de ejes sólo sale ratón y teclado.

Si me decís como puedo subir un pantallazo aquí os lo muestro.

De todas formas muchísimas gracias por tu interés.

 

Share this post


Link to post
Share on other sites
40 minutes ago, JMCAL62 said:

Encantado, Tundra.

Eso pensaba yo, que en DSC el A-10c sería plug and play aunque luego tendría que mapear muchas cosas.

Esas 90 (ya 92) horitas volando con el teclado y el ratón van a gastarme los dedos, pero me han servido para familiarizarme con el 90% del avión y sus características. Pero estoy hasta los tegumentos procreativos ya. Con el equipo que me han traído los Reyes y sin poderlo usar.

Pero insisto, el problema es que en configuración/A-10C sim/asignación de ejes sólo sale ratón y teclado.

Si me decís como puedo subir un pantallazo aquí os lo muestro.

De todas formas muchísimas gracias por tu interés.

 

 

el throttle se te ilumina cuando conectas el USB?

 

technology_174a_030.jpg

 

Si no recuerdo mal, hay que enchufar primero los gases y luego el joy.

En serio, no sé cómo puedes volar haciendo TMS, DMS, CMS, y demás con el teclado.

 

  • Like 1

Share this post


Link to post
Share on other sites
El hace 1 minuto, Tundra dijo:

 

el throttle se te ilumina cuando conectas el USB?

 

technology_174a_030.jpg

 

Si no recuerdo mal, hay que enchufar primero los gases y luego el joy.

En serio, no sé cómo puedes volar haciendo TMS, DMS, CMS, y demás con el teclado.

 

Sí, se me ilumina el throttle y los MFD. Lo del teclado es nivel Dios del Olimpo, así que cuando esto funcione, que se prepare Putin.

Como puedo poner aquí una foto o imagen para enseñarlo (mil perdones por mi torpeza) y nuevamente gracias.

Share this post


Link to post
Share on other sites
1 hour ago, JMCAL62 said:

Sí, se me ilumina el throttle y los MFD. Lo del teclado es nivel Dios del Olimpo, así que cuando esto funcione, que se prepare Putin.

Como puedo poner aquí una foto o imagen para enseñarlo (mil perdones por mi torpeza) y nuevamente gracias.

 

Ok, pues arrancas DCS, vas arriba a configuración, le das a la pestaña de controles y solo te aparecen 2 columnas, la de teclado y la de ratón.

Es así, no?

Y aunque estés en A-10C Sim , y presiones por ejemplo el CMS derecha, no te sale resaltado el control pulsado?

No tendrás las columnas sin espacio de ancho, como si fueran columnas de un Excel , si pasas el rato por la fila superior, donde pone  "Acción    |     Categoría    |   Teclado  |  Ratón "    ,   verás que el cursor cambia y se transforma en una linéa negra con flechas.

A lo mejor tus columnas de joystick y gases están muy pequeñas y quedan ocultas???

 

Otra opción, si pinchas arriba en el botón gris de "resetear a asignaciones por defecto", te hace algo?

  • Like 1

Share this post


Link to post
Share on other sites
El hace 5 horas, overlord74 dijo:

Con el A10 si, es verdad , con el resto a mi me los pillo como cuadro...habia un despiporre de ejes duplicados.

 

El hace 2 horas, Tundra dijo:

 

Ok, pues arrancas DCS, vas arriba a configuración, le das a la pestaña de controles y solo te aparecen 2 columnas, la de teclado y la de ratón.

Es así, no?

Y aunque estés en A-10C Sim , y presiones por ejemplo el CMS derecha, no te sale resaltado el control pulsado?

No tendrás las columnas sin espacio de ancho, como si fueran columnas de un Excel , si pasas el rato por la fila superior, donde pone  "Acción    |     Categoría    |   Teclado  |  Ratón "    ,   verás que el cursor cambia y se transforma en una linéa negra con flechas.

A lo mejor tus columnas de joystick y gases están muy pequeñas y quedan ocultas???

 

Otra opción, si pinchas arriba en el botón gris de "resetear a asignaciones por defecto", te hace algo?

Correcto, es como dices, solo aparecen las columnas del teclado y el ratón. No hay columnas ocultas por estrechas en plan Excel tal como me indicabas (¡me ilusionó mucho pensar que este fuera el problema!) y no pasa nada cuando pulso el botón de reseteo que me indicas.

¡Estoy desesperado!

Share this post


Link to post
Share on other sites

También puedes probar a desenchufarlos, y conectarlos a puertos USB de detrás de la torre, y comprobar que Windows pita cuando los conectas.

  • Like 1

Share this post


Link to post
Share on other sites
El hace 3 horas, Tundra dijo:

También puedes probar a desenchufarlos, y conectarlos a puertos USB de detrás de la torre, y comprobar que Windows pita cuando los conectas.

Los he desconectado, desistalado los controladores, desistalado DCS, vuelto a instalar primero DCS (lo tengo en Steam) y controladores de nuevo...y nada.

¿Podría tener algo que ver la carpeta donde se instalaran los controladores? ¿Tendría que ser la misma o no tiene nada que ver?

 

Share this post


Link to post
Share on other sites

No tiene nada que ver la carpeta donde instales los drivers...

 

¿Y tu windows reconoce los dispositivos? Mira en configuración - dispositivos e impresoras si aparecen ahí el Joystick y el Throttle. 

  • Like 1

Share this post


Link to post
Share on other sites

Si windows los reconoce, al entrar en DCS deberian de aparecer en la pantalla de controles, busca una pestaña ahi que pone ejes a ver si te salen ahi.

  • Like 1

Share this post


Link to post
Share on other sites
4 hours ago, JMCAL62 said:

dice que funcionan correctamente

 

creo que no has mirado donde te ha dicho Angel, cuidado no confundas el administrador de dispositivos (ahí no), con dispositivos e impresoras (ahí si), donde, con boton dcho,  configuración dispositivo de juego, propiedades, ves si funcionan los ejes y los botones.

  • Like 1

Share this post


Link to post
Share on other sites

Esa es mi desesperación, Angel, que hago todo eso y no me aparece pestaña alguna en controles porque no detecta el HOTAS (ni los MFD ni los Pedales). ¡Y en FSX sí lo hace! ¡Y Windows los reconoce y dice que funcionan correctamente.

Pues nada, ni en DCS, ni el IL2, ni en Elite Dangerous.

De locura. Mi frustración os podéis imaginar hasta donde llega, casi 600€ de momento para nada. 

 

Share this post


Link to post
Share on other sites
El hace 4 minutos, Deute dijo:

 

creo que no has mirado donde te ha dicho Angel, cuidado no confundas el administrador de dispositivos (ahí no), con dispositivos e impresoras (ahí si), donde, con boton dcho,  configuración dispositivo de juego, propiedades, ves si funcionan los ejes y los botones.

Sí, Deute, es ahí donde he comprobado que los periféricos funcionan perfectamente tanto en sus ejes como en sus botones.

¡Ya no sé qué hacer!

 

Share this post


Link to post
Share on other sites

¿Los tienes conectados directos a la placa o a través de algún concentrador usb?

 

No tiene lógica que te pase eso, vamos eres el primero que leo que viene con esos problemas de un warthog.

  • Like 1

Share this post


Link to post
Share on other sites

Los tengo a través de un concentrador, pero en el funcionan con el FSX como te comento.

Voy a probar a conectarlos directos a la placa y os digo.

 

El hace 38 minutos, Deute dijo:

 

creo que no has mirado donde te ha dicho Angel, cuidado no confundas el administrador de dispositivos (ahí no), con dispositivos e impresoras (ahí si), donde, con boton dcho,  configuración dispositivo de juego, propiedades, ves si funcionan los ejes y los botones.

 

El hace 14 minutos, Angel101 dijo:

¿Los tienes conectados directos a la placa o a través de algún concentrador usb?

 

No tiene lógica que te pase eso, vamos eres el primero que leo que viene con esos problemas de un warthog.

 

Share this post


Link to post
Share on other sites
El hace 7 minutos, JMCAL62 dijo:

Los tengo a través de un concentrador, pero en el funcionan con el FSX como te comento.

Voy a probar a conectarlos directos a la placa y os digo.

 

 

 

 

Pues yo creo recordar que los conecté a un concentrador y los tuve que quitar y ponerlos en los usb detrás de la torre.

Prueba a ver que tal.

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now